Wednesday, May 19, 2010

Getting runInstaller to accept your version

Of course, you can start with the "-ignoreSysPrereqs" switch, but if you just want to see if all is OK, fool the installer by tweaking oraparam.ini (in the install subdirectory) by adding the correct version.

I am running CentOS 5.5 (Final), which is indicated by the contents of the file /etc/redhat-release:
[oracle@oracleas install]$ cat /etc/redhat-release
CentOS release 5.5 (Final)

The oraparam.ini file looks like:
[Certified Versions]
Linux=redhat-Red Hat Enterprise Linux AS release 4,redhat-2.1,redhat-3,SuSE-9,UnitedLinux-1.0

[Linux-redhat-Red Hat Enterprise Linux AS release 4-optional]

Change that to:(mind you: two places, although the second one is not very omportant)
[Certified Versions]
Linux=redhat-CentOS release 5.5 (Final),redhat-3,SuSE-9,UnitedLinux-1.0

[Linux-redhat--CentOS release 5.5 (Final)-optional]

and you have managed to trick the installer into believing this was the correct and supported version to start with:
[oracle@oracleas install]$ ./runInstaller -paramFile /home/oracle/oraparam.ini
Starting Oracle Universal Installer...

Checking installer requirements...

Checking operating system version: must be redhat-CentOS release 5.5 (Final), redhat-3, SuSE-9 or UnitedLinux-1.0

All installer requirements met.

1 comment:

PhaE said...

You could also just temporarily change the /etc/redhat-release;

mv /etc/redhat-release /etc/redhat-release.orig
echo "redhat-3" > /etc/redhat-release

-do stuff-

rm /etc/redhat-release
mv /etc/redhat-release.orig /etc/redhat-release